HACKER RANK Algorithms - Implementation - Sherlock and Squares - Solution.'C++'
Algorithms - Implementation - Sherlock and Squares - Solution
Problem Statement
Watson gives two integers (A and B ) to Sherlock and asks if he can count the number of square integers between A and B (both inclusive).
Note: A square integer is an integer which is the square of any integer. For example, 1, 4, 9, and 16 are some of the square integers as they are squares of 1, 2, 3, and 4, respectively.
Input Format
The first line containsT , the number of test cases. T test cases follow, each in a new line.
Each test case contains two space-separated integers denotingA and B .
The first line contains
Each test case contains two space-separated integers denoting
Output Format
For each test case, print the required answer in a new line.
For each test case, print the required answer in a new line.
Constraints
1≤T≤100
1≤A≤B≤109
Sample Input
2
3 9
17 24
Sample output
2
0
Explanation
Test Case #00: In range[3,9] , 4 and 9 are the two square numbers.
Test Case #01: In range[17,24] , there are no square numbers.
Test Case #00: In range
Test Case #01: In range
Solution:
#include <iostream>
#include <vector>
using namespace std;
int main()
{
vector<int> squares;
for(int i=1;i<=32000;++i)
squares.push_back(i*i);
int t;
cin>>t;
for(int k=1;k<=t;++k)
{
int a,b;
cin>>a>>b;
int ans=0;
for(int i=0;i<squares.size();++i)
if(squares[i]>=a && squares[i]<=b)
++ans;
cout<<ans<<endl;
}
return 0;
}
#include <iostream>
#include <vector>
using namespace std;
int main()
{
vector<int> squares;
for(int i=1;i<=32000;++i)
squares.push_back(i*i);
int t;
cin>>t;
for(int k=1;k<=t;++k)
{
int a,b;
cin>>a>>b;
int ans=0;
for(int i=0;i<squares.size();++i)
if(squares[i]>=a && squares[i]<=b)
++ans;
cout<<ans<<endl;
}
return 0;
}
Comments
Post a Comment