HACKER RANK Algorithms Sorting Challenges - Insertion Sort - Part 2 Solution.'C++'

Algorithms Sorting Challenges - Insertion Sort - Part 2 Solution
Problem Statement
In Insertion Sort Part 1, you sorted one element into an array. Using the same approach repeatedly, can you sort an entire unsorted array?
Guideline: You already can place an element into a sorted array. How can you use that code to build up a sorted array, one element at a time? Note that in the first step, when you consider an element with just the first element - that is already "sorted" since there's nothing to its left that is smaller.
In this challenge, don't print every time you move an element. Instead, print the array after each iteration of the insertion-sort, i.e., whenever the next element is placed at its correct position.
Since the array composed of just the first element is already "sorted", begin printing from the second element and on.
Input Format 
There will be two lines of input:
  •  - the size of the array
  •  - a list of numbers that makes up the array
Output Format 
On each line, output the entire array at every iteration.
Constraints 

Sample Input
6
1 4 3 5 6 2
Sample Output
1 4 3 5 6 2 
1 3 4 5 6 2 
1 3 4 5 6 2 
1 3 4 5 6 2 
1 2 3 4 5 6 
Explanation 
Insertion Sort checks first and doesn't need to move it, so it just prints out the array. Next, is inserted next to , and the array is printed out. This continues one element at a time until the entire array is sorted.
Task 
The method insertionSort takes in one parameter: , an unsorted array. Use an Insertion Sort Algorithm to sort the entire array.

Solution:

#include <vector>
#include <iostream>

void print(const std::vector<int>& v) {
    for (auto x : v) {
        std::cout << x << ' ';
    }
    std::cout << '\n';
}

int main() {
    int s;
    std::cin >> s;
    std::vector<int> sorted(s);
    int i = 0;
    while (std::cin && i != s) {
        std::cin >> sorted[i++];
    }
    for (std::size_t i= 1; i < sorted.size(); ++i) {
        std::size_t j = i;
        for (std::size_t k = 0; k < j; ++k) {
            if (sorted[j] < sorted[k]) {
                std::swap(sorted[j],sorted[k]);
            }
        }
        print(sorted);
    }
}

Thanks for Visiting, Hope this helps you....

Copyright © 2015 HackerRank.
All Rights Reserved

Comments

Popular Posts